月度归档: 2020 年 4 月

  • Switch lan-play原理

    Switch的机器要是被ban了(原因可能有很多,比如买了淘宝数字版。。。),最大的问题就是不能联网了,但是部分游戏是支持局域网联机和当面联机的,所以理论上是可以一起玩的。

    lan-play的作用就是可以让大家在网络环境下也做到当面联机或者局域网联机的效果,这样足不出户就可以和朋友联机。

    由于最近用lan-play老是炸岛,所以花时间看了下大致原理。lan-play大体工作原理如下:

    其中电脑运行了lan-play client,它会和私服链接。而你的Switch需要和电脑链接同一个路由器。

    Switch和lan-play client的通讯

    Switch和lan-play client在一个路由下,而Switch上配置的IP和Gateway地址配置了10.31.XX.XX和10.13.37.1,但是实际上lan-play并没有在这个IP提供服务,而是通过pcap监听相关的包,这就是为什么安装lan-play的第一步是安装pcap。

    pcap是一个抓包工具,支持协议比较广泛,包括

    • Ethernet, Linux SLL, raw IP, PPP (RFC1661, RFC1662), BSD (Mac OS X) loopback encapsulation, and Radiotap
    • IEEE 802.11
    • Probe Request
    • LLC and SNAP
    • IEEE802.1Q
    • ARP
    • IPv4 (RFC791 and RFC1349) and
    …